Publicado Kali Linux v2024.2

Kali Linux lanzó la versión 2024.2, con nuevas
herramientas y correcciones para el error Y2038.

Como es típico en la primera versión del año, Kali Team ha lanzado nuevos
elementos visuales, incluidos fondos de pantalla y actualizaciones del menú de
inicio y la pantalla de inicio de sesión.

Dieciocho nuevas herramientas en Kali Linux 2024.2

Kali 2024.2 agrega dieciocho nuevas herramientas:

autorecon
Multi-threaded network reconnaissance tool

coercer – Automatically
coerce a Windows server to authenticate on an arbitrary machine

dploot – Python rewrite of
SharpDPAPI

getsploit – Command line
utility for searching and downloading exploits

gowitness – Web
screenshot utility using Chrome Headless

horst – Highly Optimized
Radio Scanning Tool

ligolo-ng – Advanced, yet
simple, tunneling/pivoting tool that uses a TUN interface

mitm6 – pwning IPv4 via IPv6

netexec – Network service
exploitation tool that helps automate assessing the security of large
networks.

pspy – Monitor Linux processes
without root permissions

pyinstaller – Converts
(packages) Python programs into stand-alone executables.

pyinstxtractor
PyInstalller Extractor

sharpshooter – Payload
Generation Framework

sickle – Payload
development tool

snort – Flexible Network
Intrusion Detection System

sploitscan – Search for
CVE information

vopono – Run applications
through VPN tunnels with temporary network namespaces

waybackpy – Access
Wayback Machine’s API using Python

Kali dice que no tuvieron tiempo de incluir el kernel de Linux 6.8, que se
lanzó el 10 de marzo, pero que se incluirá en la versión 2024.3.

Corrección para el error del año 2038 Y2K28

Similar al error Y2K, el ‘problema del año 2038’ (también conocido como Y2038
e Y2K38) hará que la hora cambie a 1901-12-13 20:45:52 después de llegar a
2038-01-19 03:14:08 UTC en Linux sistemas cuando las marcas de tiempo UNIX se
almacenan en una variable entera time_t de 32 bits.

Para solucionar este problema, los compiladores y bibliotecas cambiaron a
enteros time_t de 64 bits más grandes que almacenan correctamente las
marcas de tiempo cuando llegamos a 2038. Sin embargo, esto requiere que las
aplicaciones y bibliotecas que utilizan las variables de 32 bits anteriores se
vuelvan a compilar para no causar problemas.

Para comenzar a usar Kali Linux 2024.2, puede actualizar la instalación
existente,
seleccionar una plataforma
o
descargar directamente imágenes ISO
para nuevas instalaciones y distribuciones en vivo.

Actualización rápida vía consola:

grep VERSION /etc/os-release
sudo apt update
sudo apt dist-upgrade

Fuente:
BC

Leave Your Comment